Directions for Step 4: Creating Your Page

PC/MAC Composition Tool Bars
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L. Opening Composer

A. Go to Netscape Communicator on the Menu Bar (top of the screen) and open the drop down
menu. Click on Composer.

B. Once the Composer screen is open, click on the New button (Composition Tool Bar #1).
You can also select New from the File Menu at the top left of the screen.

C. When you click on the New button, a dialogue box will appear. Click on Blank Page.
You are now ready to make this Blank Page, "Your Page."
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Establishing Page Properties

A. Tt is time to create your home page file name and title.
1. Go to File (top left of Menu Bar) and open the File Menu.
2. Click on Save As. A dialogue box will appear.
3. Find your A:\ Drive and open your folder.
4. Enter a short file name and click on Save.
5. The home page file name of a web site is often called index.
6. You must Save after you name your file.

B. After you save your file, a pop up dialogue box will appear and ask you to give your page
a title. Enter your title and click OK.

C. How do you open your web page file after it has been saved?
1. Close your page from the File Menu or from the close button at the top of the screen.
2. Make sure you are still in Composer.
3. Now click on the Open button (Composition Tool Bar #2).
4. In the dialogue box, check to make sure your web page folder is open.
5. Select your page file and click on the Open button.
6. Your page will reappear in the Composer work space.
7. If you use the File Menu and click on Open Page, a different dialogue box will appear.
Click on Choose File, find your file location, and proceed to open your file.

D. The Page Properties (MAC) or Page Colors and Properties (PC) dialogue box is accessed from
the Format menu at the top of the screen.
1. Open the Format Menu and click and open Page Properties.
2. There are three folders at the top of the box.
3. For your first web page, you will need the General folder and the Colors and Background
folder.

E. Page Properties: Click on the General folder tab. The three important parts of this box are
1. Title: This is the name you have already given your page, but it can be changed now
or later.
2. Location: This should show your file name and folder name.
3. Author: Enter your name in this space.

F. Page Properties: If not already visible, click on Colors and Background folder tab. You will start
with the choices on the left side of the dialogue box. The right side displays your color
selections.

1. Click on the first button to select the default colors of the viewer's browser. Some
people find this boring, but it saves time and is a sure thing.

2. Define your own colors. Click on ...custom colors... Starting with Normal Text,
choose your own color by clicking on the color button next to the text description.
A color chart will appear for you to make your color selection.
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3. Color Schemes.

a. PC: Find the headline Color Schemes. Next to this headline you see a
blank space with an arrow to the right. Click on the arrow to open a list
of coordinated color schemes. Click on the color scheme's name to see
how it looks.

b. MAC: Look for the gray bar to the right of the Custom Colors button.
Click on the arrows to open a list of coordinated color schemes. Click on
the color scheme's name to see how it looks.

4. When you gain confidence in designing your page, you may wish to use a
Background image file that you have found in a clip art collection. This would take
the place of a plain background color. This image would be inserted in your page by
following the directions in the Background Image section of the dialogue box.

5. Don't forget to click OK at the bottom of the Colors and Background box when
you are finished!

Adding Text-General

A. Two ways to add text to your web page.
1. Type your text in the Composer work space.
2. Copy/Paste text from a word processed document.

B. Default styles.
1. You have already chosen font colors, and there is a default font size and style.
2. The default style for your text appearance is a prose paragraph style.
3. If you wish to change any aspect of the text, you must use the Composer format options.

C. Two ways to format text. Commands are similar to those found in word processing applications.
1. For initial formatting or reformatting particular words, lines, or sections of
text, follow the arrows in the drop down Format Menu.
2. You can also reformat words, lines, or sections of text from the Text Format Tool Bar.

D. Using Heading for titles.

1. Heading automatically increases font size for page and section titles.

2. Heading sizes #1 and #2 are the best to use for titles.

3. Heading can be accessed either from the Format Menu or from the Text Format Tool Bar
(Text Format Tool Bar #1).

4. To use Heading, click on Heading and select the Heading size you want to use; then type
the title in the Composer work space.

5. When you finish the title, press Enter to revert to your normal font size and style.

E. Word wrapping and indenting.
1. In paragraph style, words will wrap to the next line automatically.
2. If you want a slight indent for a second line you can create a line break by pressing
Shift + Enter.
3. TAB ISN'T TAB! In order to indent text you must use the Indent button (Text Format
Tool Bar #11).
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4. "Unindent" by using the Decrease Indent button (#10).

F. Some Advice: Readability!
1. Unless you have a compelling reason for a fancy font, stick with the default font style.
2. Size of font is also important. Either default or larger font should be used.
3. Don't be wordy with text. Shorter is better.
4. Centering text (Text Format Tool Bar--Alignment button #12) is popular but not visually
useful, except maybe for titles.
5. Keep your text left aligned. Your readers' eyes will be happy.

G. Begin Typing. See Outline.
1. Type your page title at the top of the Composer work space. Use Heading style #1 or #2.
2. Type your welcome and/or goal statement.
3. Now click on Save (Composition Tool Bar #3).

H. Using Preview
1. What you see in Composer is not necessarily what you will get Navigator.
2. After you have saved your work, click on the Preview button (Composition Tool Bar #5).
3. This view shows you how your page will look on the web.
4. Check Preview often to see if changes are needed.
5. You must close Preview (from File Menu or button at the top right of the screen) to
return to Composer.

Inserting Graphics

A. Graphics and web pages.
1. There is no doubt that graphics enliven a web page.
2. At the same time, the over-use of graphics can be a distraction.
3. Graphics also take up a lot of space and can substantially lengthen the amount of time
it takes to load your page.
4. Use graphics, but use them wisely.

B. Graphics Files
1. Each image file that you want to use in your web page must be saved in your web page
folder because each image file must be separately uploaded when you publish your
page.
2. Browse through the selection of clip art has been provided for you (see Clip Art List),
and make a note of the page number for a few images you might use in your page.

C. Saving Graphics--See Online version of this tutorial, "Inserting Graphics," to access clip
art collection pages.
1. Directions--PC
a. Find and right click on an image. A pop-up menu will appear.
b. Left click on Save Image as. A Save As box will appear.
c. Notice that the image file name and extension are already visible.
d. Select the A:\ drive and open your web page folder.
e. Click on Save.



2. Directions--MAC
a. Find and click on an image. Hold the mouse as you scroll down the
pop up menu that appears.
b. Release the mouse on Save Image as. A Save As box will appear.
c. Notice that the image file name and extension are already visible.
d. Select the A:\ drive and open your web page folder.
e. Click on Save.

3. Repeat this process for each image you want to use.

D. Add a graphic to your page title or introduction statement.
1. Find the spot on your page where you will insert the image. Click on this location.
2. Click on Image (Composition Tool Bar #13) to open the Image Properties
dialogue box. (You can also do this from Insert on the Menu Bar.)
. Click on Choose File.
. In the Choose Image File box, click on the file name of your image.
. Click on Open to return to the Image Properties box.
. Find Text alignment and wrapping....
a. PC = line of button options.
b. MAC = a button/arrow to reveal options.
c. Use these buttons to choose how your image will relate to neighboring text.
d. Click on the placement style you prefer.
e. If you choose text wrapping, it will only look "wrapped" in Navigator.
7. Click OK to exit the Image Properties box.
8. The Composer work space is visible, and your image is where you placed it.
9. If you don't like what you see, you can eliminate the image by a backspace.
0. If you want to try a new alignment, click on the image and reopen the Image
Properties dialogue box.
11. Click OK when you have made your change.
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V. Organizing Information Netscape Composer provides four aids to help you organize
your information: Indent; Bullet and Numbered Lists; Horizontal Lines; and, Tables.

A. Indent (Text Format Tool Bar #11) is a useful tool for information that can be outlined.

1. Under your web page welcome statement, type the four topic headings from II. of
your Outline.

2. Under Teacher Recommended Web Sites type Alta Vista, and under Alta Vista,
type Homework Central. You will create links for these later.

3. Place your pointer in front of the "A" in Alta Vista and click on Indent.

4. Now indent Homework Central.

5. You can reverse Indent by clicking on the Decrease Indent button
(Text Format Tool Bar #10).



B. Bullet (Text Format Tool Bar #8) and Numbered Lists (#9).
1. Lists with bullets or numbers focus the reader's attention and emphasize the outline
context of a list.
. Start a bullet/numbered list by clicking on button #8 or #9.
. When you use these features, the line spacing for the list will automatically double
space from text above it.
4. The line spacing for the items in the list will be a single space.
5. Additional lines of type will align to the right of the bullet or number.
6. The next bullet/numbered item will not begin until you press Enter.
7. You can end the list by a second click on the bullet/number button at the beginning
of a line.
8.You can extend the outline with sub topics by using Indent again.
(For a bulleted list in Composer, each new indent uses a new bullet symbol.)
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Y our outline would look like this.
* For a bullet list
* an indent at the beginning of this line,
* moves the text, and, in Composer, a new bullet symbol would appear.
* You bring the list back to the first bullet style by clicking on Decrease Indent
(Text Format Tool Bar #10).

1. A numbered list,
1. will work the same way, but each indent will re-start with the #1,
1. and the numbers might become confusing.
2. Maybe a combination list--bullets and numbers--would work better for an
extended outline.
3. Numbered lists are tricky because only the number sign (#) appears in Composer.
4. The actual number only appears in Preview/Navigator.

9. Try using bullets or numbers for your indented Alta Vista and Homework Central.

C. Horizontal Lines

1. Horizontal lines are often used as dividers for a long web page to alert the reader
to the end of a section.

2. A Horizontal line is inserted by clicking on the Insert H. Line button
(Composition Tool Bar #14).

3. After inserting a line, you can adjust its appearance by a double click on the line itself.
a. A dialogue box will appear.
b. You should have no trouble understanding the options presented.
c. If you don't like the results, double click on the line again and make new

adjustments in the properties box that appears.

4. Fancier lines are available in clip art collections. This type of line would inserted

as an image file.



D. Tables
1. Tables are probably the only way to align side-by-side lists and/or text.
2. Tables are explained in the Intermediate Composer Tutorial.

VI.  Creating Links

A. Links can connect sections of one page by establishing targets. Directions for this task
can be found in Intermediate Composer.

B. Links are easy to create. The basic steps are:
1. Select (highlight) the text or picture on your page that you want
to link to something else.
2. Click on Link (Composition Tool Bar #11) to open the Link dialogue box.
3. Type the appropriate information in the dialogue box and click OK.

C. Linking your web page to someone else's web page.

1. Find and select Alta Vista on your home page.

2. Click on Link to open the Format: Link dialogue box.
a. PC: Under, "Link to a page location or local file," type http://www.altavista.com
b. MAC: Section wording is slightly different--"URL (Page Location) or File."
c. Click OK.

3. The selected words, Alta Vista, now form an active link to a search engine that many
students like to use.

4. If you place your pointer somewhere over this link, you will see its address in the gray
bar at the bottom of the Composer screen.

5. Repeat the process to link Homework Central to http://www.homeworkcentral.com

6. Don't forget save your page changes (Composition Tool Bar #3).

D. Linking to different pages within a web site. You will now create a web site by adding
a second page to link to your home page.

E. Creating a second page and linking it back to the home page.
1. Go to New and create a page called students.
a. Make students the title and the file name for now.
b. If you have forgotten how to do this, follow the directions in Establishing
Page Properties.
. At the top of this page, use Heading # 2 and type Students' Favorite Web Sites.
. Go down a few spaces and type Home.
. Select Home and open the Link dialogue box.
. Under "...page location or...file," type the file name of your first page.
(Instead of typing in your file name, you can also click on Choose File to find
and enter your file name.)
. Click OK, and then, Save.
7. You now have a web site with two pages and one link from the students page back
to your home page.
8. Close the students page from the File Menu.
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F. Linking the home page to the (2nd) students page.

1.
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Your home page should still be visible in Composer. If not, open your home page.

2. Select the topic title, Students' Favorite Web Sites.
3.
4. Under "...page location or...file," type the file name of your students page

Open the Link dialogue box.

(students.html?).

. Once again, instead of typing in your file name, you can also click on Choose File to

find and enter your file name.

. Click OK, and then Save.
. Both of your pages are linked to each other.
. Check your links in Preview.

G. To remove a link,

1.
. open the Link dialogue box,

. click on Remove Link, and

. click on OK.

. Warning: A link will remain active if you don't cut it off.
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select the link,

a. Try this-- Choose one of your links.

b. Place your pointer at the end of the link and add five spaces.

c. If the link line continues, the link is still active and could cause text problems.
d. Select the extended part of the link and remove it.



